'

Progress Telerik Report Server Flaw Let Attackers Bypass Authentication

A new vulnerability related to authentication bypass was discovered in the Progress Telerik Report server.

The CVE for this vulnerability has been assigned CVE-2024-4358, and its severity has been given as 9.8 (Critical).

This vulnerability exists in Telerik Report Server 2024 Q1 (10.0.24.305) and earlier.

However, Progress has fixed this vulnerability in the latest versions, and a security advisory has been released.

All-in-One Cybersecurity Platform for MSPs to provide full breach protection with a single tool, Watch a Full Demo 

Technical Analysis – CVE-2024-4358

According to the reports shared with Cyber Security News, exploiting this vulnerability could allow an unauthenticated threat actor to access the Telerik Report Server’s restricted functionality by Spoofing

Though there have been no reports of this vulnerability being exploited in the wild by threat actors, it is still recommended for users to review the list of local users present on the server that were not added in the {host}/Users/Index.

If additional users are present on the server, it may likely mean that the server has been exploited.

Nevertheless, further details about this vulnerability are yet to be published. 

Progress mentioned that the only way to fix this vulnerability is to update the version to Report Server 2024 Q2 (10.1.24.514) or later.

This vulnerability was mentioned to be reported by Sina Kheirkhah of the Summoning Team working with Trend Micro Zero Day Initiative.

Users of the Progress Telerik Report Server are advised to upgrade their servers to the latest versions to prevent the exploitation of this vulnerability. 

Get special offers from ANY.RUN Sandbox. Until May 31, get 6 months of free service or extra licenses. Sign up for free.

The post Progress Telerik Report Server Flaw Let Attackers Bypass Authentication appeared first on GBHackers on Security | #1 Globally Trusted Cyber Security News Platform.


Go to Source
Author: Eswar