'

Apache OFBiz RCE Flaw Let Attackers Execute Malicious Code Remotely

Many businesses use enterprise resource planning (ERP) systems like Apache OFBiz.

However, it has been found to have significant security holes that let attackers run harmful code from afar without being verified.

Businesses that depend on Apache OFBiz for budgeting, human resources, managing orders, and selling online are worried about security holes.

Free Webinar on Live API Attack Simulation: Book Your Seat | Start protecting your APIs from hackers

List of Known Apache OFBiz Vulnerabilities

Apache OFBiz has experienced a series of vulnerabilities over the years that have affected various releases.

Below is a detailed list of these vulnerabilities, specifying the affected versions and the updates that addressed these issues:

  • CVE-2024-32113: Impacted versions before 18.12.13; resolved in 18.12.13 with commits b3b87d98dd, ff316b6e22.
  • CVE-2024-23946: Impacted versions prior to 18.12.12; resolved in 18.12.12 with commits b1cf4ef3e1, 93f8a58419, c910e413ba.
  • CVE-2024-25065: Impacted versions before 18.12.12; resolved in 18.12.12 with commit b91a9b7f26.
  • CVE-2023-51467: Impacted versions before 18.12.11; resolved in 18.12.11 with commits d8b097f, 1dcfa07180.
  • CVE-2023-50968: Impacted versions before 18.12.11; resolved in 18.12.11 with commit 82c1737688.
  • CVE-2023-49070: Impacted version 18.12.09; resolved in 18.12.10 with commit c59336f604.
  • CVE-2023-46819: Impacted version 18.12.08; resolved in 18.12.09 with commit 998bf510a.
  • CVE-2022-25371: Impacted version 18.12.07; resolved in 18.12.08 with commit 41ff12cf8.
  • CVE-2022-47501: Impacted versions before 18.12.07; resolved in 18.12.07 with commit 582add7d3.
  • CVE-2022-25813: Impacted versions before 18.12.06; resolved in 18.12.06 with multiple commits.
  • CVE-2022-29063: Impacted versions before 18.12.06; resolved in 18.12.06 with commit 061252a80.
  • CVE-2022-29158: Impacted versions before 18.12.06; resolved in 18.12.06 with commit ff92c4bc9.
  • CVE-2022-25370: Impacted versions before 18.12.06; temporarily resolved by disabling the Birt component.
  • CVE-2021-45105: Impacted all releases before 17.12.09 and 18.12.04; resolved in both versions with multiple commits.
  • CVE-2021-44228: Impacted all releases before 17.12.09 and 18.12.03; resolved in both versions with multiple commits.
  • https://nvd.nist.gov/vuln/detail/CVE-2021-37608
  • CVE-2021-37608: Impacted all releases before 17.12.08; resolved on 17.12.08.
  • CVE-2021-30128: Impacted all releases before 17.12.07; resolved on 17.12.07 with multiple commits.
  • CVE-2021-29200: Impacted all releases before 17.12.07; resolved in 17.12.07.
  • CVE-2021-26295: Impacted all releases before 17.12.07; resolved in 17.12.06.
  • CVE-2020-9496: Impacted release 17.12.03; resolved in 17.12.04.
  • CVE-2020-13923: Impacted all releases before 17.12.04; resolved in 17.12.04.
  • CVE-2019-12425: Impacted release 17.12.01; resolved in 17.12.03.
  • CVE-2019-0235: Impacted release 17.12.01; resolved in 17.12.03.
  • CVE-2020-1943: Impacted releases from 16.11.01 to 16.11.07; resolved in 17.12.01.
  • CVE-2019-12426: Impacted releases from 16.11.01 to 16.11.06; resolved in 16.11.07.
  • CVE-2018-17200: Impacted releases from 16.11.01 to 16.11.05; resolved in 16.11.06.
  • CVE-2019-0189: Impacted releases from 16.11.01 to 16.11.05; resolved in 16.11.06.
  • CVE-2019-10073: Impacted releases from 16.11.01 to 16.11.05; resolved in 16.11.06.
  • CVE-2019-10074: Impacted releases from 16.11.01 to 16.11.05; resolved in 16.11.06.
  • CVE-2018-8033: Impacted releases from 16.11.01 to 16.11.04; resolved in 16.11.05.
  • CVE-2011-3600: Impacted releases from 16.11.01 to 16.11.04; resolved in 16.11.05.
  • CVE-2017-15714: Impacted releases from 16.11.01 to 16.11.03; resolved in 16.11.04.
  • CVE-2016-6800: Impacted releases 13.07., 12.04., 11.04.*; resolved in 16.11.01.
  • CVE-2016-4462: Impacted releases 13.07., 12.04., 11.04.*; resolved in 16.11.01.
  • CVE-2016-2170: Impacted releases 13.07.02 and 12.04.05 and earlier; resolved in subsequent versions.
  • CVE-2015-3268: Impacted releases 13.07.02 and 12.04.05 and earlier; resolved in subsequent versions.
  • CVE-2014-0232: Impacted releases 12.04.03 and 11.04.04 and earlier; resolved in subsequent versions.
  • CVE-2013-2250: Impacted releases 12.04.01, 11.04.02, and earlier; resolved in subsequent versions.
  • CVE-2013-2137: Impacted releases 12.04.01, 11.04.02, and earlier; resolved in subsequent versions.
  • CVE-2013-0177: Impacted releases 11.04.01, 10.04.04, and earlier; resolved in subsequent versions.
  • CVE-2012-3506: Impacted releases 10.04.02, 10.04.01; resolved in 10.04.03.
  • CVE-2012-1622: Impacted release 10.04.01; resolved in 10.04.02.
  • CVE-2012-1621: Impacted release 10.04.01; resolved in 10.04.02.
  • CVE-2010-0432: Impacted release 09.04; resolved in 09.04.01.

To lower their risk, users of Apache OFBiz should update to version 18.12.11 as soon as possible.

The ASF Security Team also tells users that if they find security issues with OFBiz, they should report them to their private security email lists instead of public forums.

This is to stop the problems from being widely used.

This set of flaws shows the importance of always being on guard and applying patches quickly in cybersecurity.

Businesses that use Apache OFBiz must immediately protect their systems from these serious threats.

This will keep their operations and private data safe from possible cyberattacks.

Is Your Network Under Attack? - Read CISO’s Guide to Avoiding the Next Breach - Download Free Guide

The post Apache OFBiz RCE Flaw Let Attackers Execute Malicious Code Remotely appeared first on GBHackers on Security | #1 Globally Trusted Cyber Security News Platform.


Go to Source
Author: Divya