'

Critical WordPress Plugin Flaw Exposes 90,000+ WordPress Sites

A critical vulnerability has been discovered in the popular WordPress plugin “Email Subscribers by Icegram Express – Email Marketing, Newsletters, Automation for WordPress & WooCommerce.”

The flaw, identified as CVE-2024-6172, has been assigned a CVSS score of 9.8, indicating its severe impact.

The vulnerability was publicly disclosed on July 1, 2024, and last updated on July 2, 2024, by the researcher known as shaman0x01 from the Shaman Red Team.

CVE-2024-6172 – Vulnerability Details

According to the Wordfence blog, the vulnerability affects all plugin versions up to and including 5.7.25.

It stems from insufficient escaping of the user-supplied db parameter and inadequate preparation on the existing SQL query.

This flaw allows unauthenticated attackers to execute time-based SQL Injection attacks, enabling them to append additional SQL queries into existing ones.

Consequently, attackers can extract sensitive information from the database, posing a significant risk to the security and privacy of the affected websites.

"Is Your System Under Attack? Try Cynet XDR: Automated Detection & Response for Endpoints, Networks, & Users!"- Free Demo

The “Email Subscribers by Icegram Express” plugin is widely used for email marketing, newsletters, and automation on WordPress and WooCommerce sites.

With over 90,000 active installations, the potential impact of this vulnerability is extensive.

Websites using this plugin are at risk of data breaches, which could expose sensitive user information, including email addresses, passwords, and other personal data.

Research and Discovery

The vulnerability was discovered by shaman0x01, a researcher from the Shaman Red Team, with a track record of identifying critical security flaws.

The researcher’s findings highlight the importance of proper input validation and query preparation in preventing SQL Injection attacks.

Notably, CVE-2024-37252 appears to duplicate this issue, underscoring the critical nature of the vulnerability.

Website administrators using the “Email Subscribers by Icegram Express” plugin are strongly advised to mitigate the risk immediately.

The following steps are recommended:

  1. Update the Plugin: Check for any available updates from the plugin developers and apply them as soon as possible.
  2. Disable the Plugin: If an update is unavailable, consider temporarily disabling the plugin to prevent potential exploitation.
  3. Monitor for Unusual Activity: Check your website for any signs of unusual activity, such as unexpected database queries or unauthorized access attempts.
  4. Backup Data: Regularly back up your website data to ensure you can restore it in case of a security breach.

The discovery of CVE-2024-6172 is a stark reminder of the importance of robust security practices in plugin development.

As WordPress remains a popular platform for websites worldwide, ensuring the security of its plugins is crucial to maintaining the integrity and privacy of online data.

Website administrators must stay vigilant and proactive in addressing vulnerabilities to protect their sites and users from potential threats.

Are you from SOC/DFIR Teams? - Sign up for a free ANY.RUN account! to Analyse Advanced Malware Files

The post Critical WordPress Plugin Flaw Exposes 90,000+ WordPress Sites appeared first on GBHackers on Security | #1 Globally Trusted Cyber Security News Platform.


Go to Source
Author: Divya